在Ubuntu18.04下存在多版本Python如何设置默认Python和Pip?

  • A+
所属分类:Python其它

文章来源:www.xdbcb8.com,转载请注明出处。

相关文章:《ubuntu18.04下源码编译安装最新版本Python3》

我们在ubuntu18.04下面存在多个Python和Pip版本,如下图:

当我们输入python3的时候,提示是在Python3.6.7编译器下;我们输入Python3.7的时候,提示是在Python3.7.3编译器下。哎呀,好烦,我只想要一个默认的python,要怎么操作呢?

我们可以试试update-alternatives命令!

update-alternatives命令用来维护系统命令的符号链接,可以将多个文件链接到同一个符号文件上,并进行管理。

1、我们先来看下Python不同版本对应的路径:

which python3
which python3.7

2、使用update-alternatives --install建立链接

sudo update-alternatives --install /usr/bin/python python /usr/bin/python3.6 1
sudo update-alternatives --install /usr/bin/python python /usr/local/bin/python3.7 2

即我们在/usr/bin/python这个目录下,建立一个链接符号为“Python”的链接,这里指定了两个目录,分别是Python3.6和Python3.7的。那么怎么区别呢?不要急,后面还有一个数字,分别是1和2,代表了优先级,数字越大优先级越高,这里明显选择了python3.7!

3、选择要执行的版本

sudo update-alternatives --config python

这里我们直接回车就行了。

4、我们来看看效果吧!输入Python直接使用的就是Python3.7.3的编译器了。

Pip在使用上也有同样的问题

可以使用类似的解决方式,这里直接把命令写一下:

sudo update-alternatives --install /usr/bin/pip pip /usr/bin/pip3 1
sudo update-alternatives --install /usr/bin/pip pip /usr/local/bin/pip3.7 2

sudo update-alternatives --config pip

最后我们再来测试一下,我们使用pip安装一个第三方哭:flask,可以看到,Python3.7.3和Python3.6.7一开始都是不能导入的,但是使用pip安装后,Python3.7.3已经可以导入了,而Python3.6.7还是不行,说明Pip已经修改成功,默认匹配Python3.7.3的了。

weinxin
学点编程吧
快来扫一扫关注吧!
小杨老师

发表评论

您必须才能发表评论!